// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)\[([^]]*)]").unwrap();
let string = "[img src=\"https://www.example.com/assets/images/logo-default-120x50.png\" width=\"120px\" height=\"80px\"]
[br][br]";
let substitution = "<$1 />";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}