re = /\[([^]]*)]/
str = '[img src="https://www.example.com/assets/images/logo-default-120x50.png" width="120px" height="80px"]
[br][br]'
subst = '<$1 />'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result