import Foundation
let pattern = #"\[([^]]*)]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
[img src="https://www.example.com/assets/images/logo-default-120x50.png" width="120px" height="80px"]
[br][br]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<$1 />"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)