use strict;
my $str = '[img src="https://www.example.com/assets/images/logo-default-120x50.png" width="120px" height="80px"]
[br][br]';
my $regex = qr/\[([^]]*)]/sp;
my $subst = '<$1 />';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";