# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<category id="(\d+)"><name>(.*?)<\\/name><short><\\/short><\\/category>/<category id="$1"><name>$2<\/name><short>$2<\/short><\/category>/gm;t' <<< "<category id=\"1\"><name>Мужские куртки</name><short></short></category>
<category id=\"2\"><name>Мужские брюки</name><short></short></category>
<category id=\"3\"><name>Мужские портянки</name><short></short></category>"