$re = '/<category id="(\d+)"><name>(.*?)<\/name><short><\/short><\/category>/m';
$str = '<category id="1"><name>Мужские куртки</name><short></short></category>
<category id="2"><name>Мужские брюки</name><short></short></category>
<category id="3"><name>Мужские портянки</name><short></short></category>';
$subst = "<category id=\"$1\"><name>$2</name><short>$2</short></category>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;