using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<category id=""(\d+)""><name>(.*?)<\/name><short><\/short><\/category>";
string substitution = @"<category id=""$1""><name>$2</name><short>$2</short></category>";
string input = @"<category id=""1""><name>Мужские куртки</name><short></short></category>
<category id=""2""><name>Мужские брюки</name><short></short></category>
<category id=""3""><name>Мужские портянки</name><short></short></category>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}