package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<category id="(\d+)"><name>(.*?)<\/name><short><\/short><\/category>`)
var str = `<category id="1"><name>Мужские куртки</name><short></short></category>
<category id="2"><name>Мужские брюки</name><short></short></category>
<category id="3"><name>Мужские портянки</name><short></short></category>`
var substitution = "<category id="$1"><name>$2</name><short>$2</short></category>"
fmt.Println(re.ReplaceAllString(str, substitution))
}