// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<category id="(\d+)"><name>(.*?)<\/name><short><\/short><\/category>"#).unwrap();
let string = "<category id=\"1\"><name>Мужские куртки</name><short></short></category>
<category id=\"2\"><name>Мужские брюки</name><short></short></category>
<category id=\"3\"><name>Мужские портянки</name><short></short></category>";
let substitution = "<category id=\"$1\"><name>$2</name><short>$2</short></category>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}