use strict;
my $str = '<category id="1"><name>Мужские куртки</name><short></short></category>
<category id="2"><name>Мужские брюки</name><short></short></category>
<category id="3"><name>Мужские портянки</name><short></short></category>';
my $regex = qr/<category id="(\d+)"><name>(.*?)<\/name><short><\/short><\/category>/mp;
my $subst = '<category id="$1"><name>$2</name><short>$2</short></category>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";