import re
regex = re.compile(r"<category id=\"(\d+)\"><name>(.*?)<\/name><short><\/short><\/category>", flags=re.MULTILINE)
test_str = ("<category id=\"1\"><name>Мужские куртки</name><short></short></category>\n"
"<category id=\"2\"><name>Мужские брюки</name><short></short></category>\n"
"<category id=\"3\"><name>Мужские портянки</name><short></short></category>")
subst = "<category id=\"$1\"><name>$2</name><short>$2</short></category>"
result = regex.sub(subst, test_str)
if result:
print(result)