#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<category id="(\d+)"><name>(.*?)<\/name><short><\/short><\/category>"
Local $sString = "<category id="1"><name>Мужские куртки</name><short></short></category>" & @CRLF & _
"<category id="2"><name>Мужские брюки</name><short></short></category>" & @CRLF & _
"<category id="3"><name>Мужские портянки</name><short></short></category>"
Local $sSubst = "<category id="$1"><name>$2</name><short>$2</short></category>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)