import Foundation
let pattern = #"<category id="(\d+)"><name>(.*?)<\/name><short><\/short><\/category>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<category id="1"><name>Мужские куртки</name><short></short></category>
<category id="2"><name>Мужские брюки</name><short></short></category>
<category id="3"><name>Мужские портянки</name><short></short></category>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<category id="$1"><name>$2</name><short>$2</short></category>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)