#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(begin[\s\S]*?\([\s\S]*?)foo([\s\S]*?\)[\s\S]*)"
Local $sString = "begin foo even spaces and maybe new line(" & @CRLF & _
"some text only replace foo foo bar foo, keep the rest" & @CRLF & _
")" & @CRLF & _
"some more text not replace foo here"
Local $sSubst = "$1abc$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)