$re = '/(begin[\s\S]*?\([\s\S]*?)foo([\s\S]*?\)[\s\S]*)/';
$str = 'begin foo even spaces and maybe new line(
some text only replace foo foo bar foo, keep the rest
)
some more text not replace foo here';
$subst = "$1abc$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;