const regex = /(begin[\s\S]*?\([\s\S]*?)foo([\s\S]*?\)[\s\S]*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(begin[\\s\\S]*?\\([\\s\\S]*?)foo([\\s\\S]*?\\)[\\s\\S]*)', '')
const str = `begin foo even spaces and maybe new line(
some text only replace foo foo bar foo, keep the rest
)
some more text not replace foo here`;
const subst = `$1abc$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);