package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(begin[\s\S]*?\([\s\S]*?)foo([\s\S]*?\)[\s\S]*)`)
var str = []byte(`begin foo even spaces and maybe new line(
some text only replace foo foo bar foo, keep the rest
)
some more text not replace foo here`)
var substitution = []byte("$1abc$2")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}