import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(begin[\\s\\S]*?\\([\\s\\S]*?)foo([\\s\\S]*?\\)[\\s\\S]*)";
final String string = "begin foo even spaces and maybe new line(\n"
+ "some text only replace foo foo bar foo, keep the rest\n"
+ ")\n"
+ "some more text not replace foo here";
final String subst = "$1abc$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}