use strict;
my $str = 'begin foo even spaces and maybe new line(
some text only replace foo foo bar foo, keep the rest
)
some more text not replace foo here';
my $regex = qr/(begin[\s\S]*?\([\s\S]*?)foo([\s\S]*?\)[\s\S]*)/p;
my $subst = '$1abc$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";