import re
regex = re.compile(r"(begin[\s\S]*?\([\s\S]*?)foo([\s\S]*?\)[\s\S]*)")
test_str = ("begin foo even spaces and maybe new line(\n"
"some text only replace foo foo bar foo, keep the rest\n"
")\n"
"some more text not replace foo here")
subst = "$1abc$2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)