// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(begin[\s\S]*?\([\s\S]*?)foo([\s\S]*?\)[\s\S]*)").unwrap();
let string = "begin foo even spaces and maybe new line(
some text only replace foo foo bar foo, keep the rest
)
some more text not replace foo here";
let substitution = "$1abc$2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}