re = /(begin[\s\S]*?\([\s\S]*?)foo([\s\S]*?\)[\s\S]*)/
str = 'begin foo even spaces and maybe new line(
some text only replace foo foo bar foo, keep the rest
)
some more text not replace foo here'
subst = '$1abc$2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result