using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(begin[\s\S]*?\([\s\S]*?)foo([\s\S]*?\)[\s\S]*)";
string substitution = @"$1abc$2";
string input = @"begin foo even spaces and maybe new line(
some text only replace foo foo bar foo, keep the rest
)
some more text not replace foo here";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}