import Foundation
let pattern = #"(begin[\s\S]*?\([\s\S]*?)foo([\s\S]*?\)[\s\S]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
begin foo even spaces and maybe new line(
some text only replace foo foo bar foo, keep the rest
)
some more text not replace foo here
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1abc$2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}