# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Z][a-z]+)\\/([A-Z][a-z]+)\\/([A-Z][a-z]+)/$1\/$2\/$3/g;t' <<< "www.domain.com/site/pool%2FPage%2FExample%2FTest"