const regex = new RegExp('([A-Z][a-z]+)\\/([A-Z][a-z]+)\\/([A-Z][a-z]+)', 'g')
const str = `www.domain.com/site/pool%2FPage%2FExample%2FTest`;
const subst = `$1/$2/$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);