import Foundation
let pattern = #"([A-Z][a-z]+)\/([A-Z][a-z]+)\/([A-Z][a-z]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"www.domain.com/site/pool%2FPage%2FExample%2FTest"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/$2/$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)