re = /([A-Z][a-z]+)\/([A-Z][a-z]+)\/([A-Z][a-z]+)/
str = 'www.domain.com/site/pool%2FPage%2FExample%2FTest'
subst = '$1/$2/$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result