import re
regex = re.compile(r"([A-Z][a-z]+)\/([A-Z][a-z]+)\/([A-Z][a-z]+)")
test_str = "www.domain.com/site/pool%2FPage%2FExample%2FTest"
subst = "$1/$2/$3"
result = regex.sub(subst, test_str)
if result:
print(result)