package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z][a-z]+)\/([A-Z][a-z]+)\/([A-Z][a-z]+)`)
var str = `www.domain.com/site/pool%2FPage%2FExample%2FTest`
var substitution = "$1/$2/$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}