$re = '/([A-Z][a-z]+)\/([A-Z][a-z]+)\/([A-Z][a-z]+)/';
$str = 'www.domain.com/site/pool%2FPage%2FExample%2FTest';
$subst = "$1/$2/$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;