using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z][a-z]+)\/([A-Z][a-z]+)\/([A-Z][a-z]+)";
string substitution = @"$1/$2/$3";
string input = @"www.domain.com/site/pool%2FPage%2FExample%2FTest";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}