use strict;
my $str = 'www.domain.com/site/pool%2FPage%2FExample%2FTest';
my $regex = qr/([A-Z][a-z]+)\/([A-Z][a-z]+)\/([A-Z][a-z]+)/p;
my $subst = '$1/$2/$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";