# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"(-?\d+(?:[\.,]\d+)?)"/\1/g;t' <<< "\"name\": \"Gnosis\", \n \"symbol\": \"GNO\", \n \"rank\": \"99\", \n \"price_usd\": \"175.029\", \n \"price_btc\": \"-0.0186887\", \n \"24h_volume_usd\": \"753877.0\"
"