use strict;
my $str = '"name": "Gnosis", \\n "symbol": "GNO", \\n "rank": "99", \\n "price_usd": "175.029", \\n "price_btc": "-0.0186887", \\n "24h_volume_usd": "753877.0"
';
my $regex = qr/"(-?\d+(?:[\.,]\d+)?)"/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";