import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(-?\\d+(?:[\\.,]\\d+)?)\"";
final String string = "\"name\": \"Gnosis\", \\n \"symbol\": \"GNO\", \\n \"rank\": \"99\", \\n \"price_usd\": \"175.029\", \\n \"price_btc\": \"-0.0186887\", \\n \"24h_volume_usd\": \"753877.0\"\n";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}