const regex = /"(-?\d+(?:[\.,]\d+)?)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(-?\\d+(?:[\\.,]\\d+)?)"', 'g')
const str = `"name": "Gnosis", \\n "symbol": "GNO", \\n "rank": "99", \\n "price_usd": "175.029", \\n "price_btc": "-0.0186887", \\n "24h_volume_usd": "753877.0"
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);