import re
regex = re.compile(r"\"(-?\d+(?:[\.,]\d+)?)\"")
test_str = ("\"name\": \"Gnosis\", \\n \"symbol\": \"GNO\", \\n \"rank\": \"99\", \\n \"price_usd\": \"175.029\", \\n \"price_btc\": \"-0.0186887\", \\n \"24h_volume_usd\": \"753877.0\"\n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)