re = /"(-?\d+(?:[\.,]\d+)?)"/
str = '"name": "Gnosis", \\n "symbol": "GNO", \\n "rank": "99", \\n "price_usd": "175.029", \\n "price_btc": "-0.0186887", \\n "24h_volume_usd": "753877.0"
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result