package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"(-?\d+(?:[\.,]\d+)?)"`)
var str = `"name": "Gnosis", \n "symbol": "GNO", \n "rank": "99", \n "price_usd": "175.029", \n "price_btc": "-0.0186887", \n "24h_volume_usd": "753877.0"
`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}