import Foundation
let pattern = #""(-?\d+(?:[\.,]\d+)?)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"name": "Gnosis", \n "symbol": "GNO", \n "rank": "99", \n "price_usd": "175.029", \n "price_btc": "-0.0186887", \n "24h_volume_usd": "753877.0"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)