# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/|author/\|autor/g;t' <<< "{{cite web|url=http://example.com|author=Ninguém}}
{{cite web|url=http://example.com|author=Alguém}}"