// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"|author").unwrap();
let string = "{{cite web|url=http://example.com|author=Ninguém}}
{{cite web|url=http://example.com|author=Alguém}}";
let substitution = "\\|autor";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}