use strict;
my $str = '{{cite web|url=http://example.com|author=Ninguém}}
{{cite web|url=http://example.com|author=Alguém}}';
my $regex = qr/|author/p;
my $subst = '\\|autor';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";