import Foundation
let pattern = #"|author"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{{cite web|url=http://example.com|author=Ninguém}}
{{cite web|url=http://example.com|author=Alguém}}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\|autor"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)