const regex = /|author/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('|author', 'g')
const str = `{{cite web|url=http://example.com|author=Ninguém}}
{{cite web|url=http://example.com|author=Alguém}}`;
const subst = `\|autor`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);