import re
regex = re.compile(r"|author")
test_str = ("{{cite web|url=http://example.com|author=Ninguém}}\n"
"{{cite web|url=http://example.com|author=Alguém}}")
subst = "\\|autor"
result = regex.sub(subst, test_str)
if result:
print(result)