$re = '/|author/';
$str = '{{cite web|url=http://example.com|author=Ninguém}}
{{cite web|url=http://example.com|author=Alguém}}';
$subst = "\|autor";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;