# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*TC: (?-s)(.*)$/<\1>/gm;t' <<< "TC: ENG6_6701
idMatches:
Close: ENG6_6701
TC: ENG6_7211
idMatches:"