const regex = /.*TC: (?-s)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*TC: (?-s)(.*)$', 'gm')
const str = `TC: ENG6_6701
idMatches:
Close: ENG6_6701
TC: ENG6_7211
idMatches:`;
const subst = `<\1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);